aboutsummaryrefslogtreecommitdiff
path: root/nix/rust.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2021-02-24 17:14:16 +0100
committerKatharina Fey <kookie@spacekookie.de>2021-02-24 18:00:47 +0100
commit5d61126be107ce5b4e3e1ae684a1cb5a625aa048 (patch)
treeaf8ff2549ce312d7e75f6d98453ae6e6e1f9fcf1 /nix/rust.nix
parenta17611983559c784be45efcfc0b01a01fcb52042 (diff)
nix: init default builder directory
Diffstat (limited to 'nix/rust.nix')
-rw-r--r--nix/rust.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nix/rust.nix b/nix/rust.nix
new file mode 100644
index 000000000000..5b1dca78f5dc
--- /dev/null
+++ b/nix/rust.nix
@@ -0,0 +1,11 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "rust-devel";
+ buildInputs = with pkgs; [
+ rust-analyzer rustc
+ cargo-watch
+ clangStdenv
+ hello
+ ];
+}