aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix
diff options
context:
space:
mode:
authorMx Kookie <kookie@spacekookie.de>2020-12-07 16:33:47 +0100
committerMx Kookie <kookie@spacekookie.de>2020-12-07 16:33:47 +0100
commitf6ae72071127e92dd82875c850a1e55dd88a9e6d (patch)
treeec0f1bd9ff576f25d87050a7cb635c1ee070fe38 /infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix
parent12e9fa77a6eb944cf0338483becc71aae63e3a75 (diff)
libkookie: adding initial i3 abstraction
This module (and associated configuration) sets up i3 on a computer, according to some parameters. At the moment, there is not much to configure, as the basics can be shared. However, I'll want to be able to change the tray, and i3bar based on the hardware, which is supported with this approach.
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix b/infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix
new file mode 100644
index 000000000000..68bd32364452
--- /dev/null
+++ b/infra/libkookie/modules/workstation/ui/i3/tools/i3-rename.nix
@@ -0,0 +1,10 @@
+/** A utility to rename the current workspace
+ *
+ * This tool relies on i3-msg, jq, and dmenu to move a window to a
+ * different workspace. In the future, maybe the display mechanism
+ * (dmenu) could be made configurable, so not to rely on nazi code.
+ */
+
+{ pkgs, ... }: with pkgs; writeShellScript "libkookie-i3-rename" ''
+ exec i3-input -F 'rename workspace to \"%s\"' -P 'New name: '
+''