aboutsummaryrefslogtreecommitdiff
path: root/ticket/Cargo.toml
diff options
context:
space:
mode:
authorMichael Gattozzi <mgattozzi@gmail.com>2019-11-21 10:59:44 -0500
committerMichael Gattozzi <mgattozzi@gmail.com>2019-11-21 14:21:07 -0500
commit2cd27b8dd40c7361f6f2b8832e210a58f30f3639 (patch)
treef52f9c39570e227f58ee498c3943e50d2e3f732c /ticket/Cargo.toml
parent5cec4e3f5c551731d1202d892da570ad62d9682d (diff)
Move find_root function into the new shared crate
This cleans up the init function using the modified find_root function for ticket and moves it into a new shared crate so that other tools that might be built can use it. This means we can easily find the root of a git repo no matter where in the repo one is and build paths relative to it. Closes #3
Diffstat (limited to 'ticket/Cargo.toml')
-rw-r--r--ticket/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/ticket/Cargo.toml b/ticket/Cargo.toml
index fd97293..3110147 100644
--- a/ticket/Cargo.toml
+++ b/ticket/Cargo.toml
@@ -12,5 +12,6 @@ colored = "1.9"
paw = "1.0"
rustyline = "5.0"
serde = { version = "1.0", features = ["derive"] }
+shared = { path = "../shared" }
structopt = { version = "0.3", features = ["paw"] }
toml = "0.5"