aboutsummaryrefslogtreecommitdiff
path: root/ticket/Cargo.toml
diff options
context:
space:
mode:
authorMichael Gattozzi <mgattozzi@gmail.com>2019-11-27 17:57:29 -0500
committerMichael Gattozzi <mgattozzi@gmail.com>2019-12-02 15:06:03 -0500
commit0caa9551a904a1ba675fbde70435de6fb0a176d6 (patch)
tree1b6224f031e13e20358f00081ef1ec91f8b118a9 /ticket/Cargo.toml
parentfc072f0656ceb99994f1217325aa11f932881d55 (diff)
Add a tui for ticket
This commit sets up a basic tui for the current functionality. It's traversable by keyboard and by mouse and shows the ticket state via tab, info in a row, and the description in it's own box when selected. This is necessary for a good user experience for in repo tools. Files are fine, but interactivity is better.
Diffstat (limited to 'ticket/Cargo.toml')
-rw-r--r--ticket/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/ticket/Cargo.toml b/ticket/Cargo.toml
index 1c5c9eb..6c752b5 100644
--- a/ticket/Cargo.toml
+++ b/ticket/Cargo.toml
@@ -15,5 +15,8 @@ serde = { version = "1.0", features = ["derive"] }
shared = { path = "../shared" }
structopt = { version = "0.3", features = ["paw"] }
toml = "0.5"
+uuid = { version = "0.8", features = ["serde", "v1"] }
log = "0.4"
pretty_env_logger = "0.3"
+tui = "0.7"
+termion = "1.5"