aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..017c4c8
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,13 @@
+with (import <nixpkgs> {});
+let
+ env = bundlerEnv {
+ name = "punchcard-bundler-env";
+ inherit ruby;
+ gemfile = ./Gemfile;
+ lockfile = ./Gemfile.lock;
+ gemset = ./gemset.nix;
+ };
+in stdenv.mkDerivation {
+ name = "cassiopeia";
+ buildInputs = [ ruby env ];
+}