aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index 0237c03..dd9bb7c 100644
--- a/default.nix
+++ b/default.nix
@@ -2,6 +2,7 @@ with import <nixpkgs> {};
stdenv.mkDerivation {
name = "website";
+ src = ./.;
buildInputs = with pkgs; [
python3
@@ -10,4 +11,16 @@ stdenv.mkDerivation {
markdown
webassets
]);
+
+ buildPhase = ''
+ runHook preBuild
+ make html
+ runHook postBuild
+ '';
+
+ installPhase = ''
+ runHook preInstall
+ mv output $out
+ runHook postInstall
+ '';
}