aboutsummaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..0237c03
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,13 @@
+with import <nixpkgs> {};
+
+stdenv.mkDerivation {
+ name = "website";
+
+ buildInputs = with pkgs; [
+ python3
+ ] ++ (with pkgs.python3Packages; [
+ pelican
+ markdown
+ webassets
+ ]);
+}