aboutsummaryrefslogtreecommitdiff
path: root/lockchain-http/Cargo.toml
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2018-06-07 02:37:23 +0200
committerKatharina Fey <kookie@spacekookie.de>2018-06-07 02:37:23 +0200
commit772f6489ded31e929ac4b09c0be71a467c089680 (patch)
treeb77c781692927329af93e0fb119d3217b0a1ea04 /lockchain-http/Cargo.toml
parent1f63146d9238dda456f6b3ff8c37cc26f765d4a1 (diff)
A bunch of code changes
Diffstat (limited to '')
-rw-r--r--lockchain-http/Cargo.toml14
1 files changed, 9 insertions, 5 deletions
diff --git a/lockchain-http/Cargo.toml b/lockchain-http/Cargo.toml
index 7cfd919..bf73979 100644
--- a/lockchain-http/Cargo.toml
+++ b/lockchain-http/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "lockchain-http"
description = "Generic HTTP interface crate for the lockchain ecosystem. Can serve both encrypted and cleartext records"
-version = "0.0.0"
+version = "0.1.0"
authors = ["Katharina Fey <kookie@spacekookie.de>"]
documentation = "https://docs.rs/lockchain-http"
@@ -13,7 +13,11 @@ license = "MIT/X11 OR Apache-2.0"
[dependencies]
lockchain-core = { version = "0.7.0", path = "../lockchain-core" }
-# Web stack
-gotham = "0.2"
-gotham_derive = "0.2"
-gotham_serde_json_body_parser = "0.2.0" \ No newline at end of file
+# Serialisation stack
+serde = "1.0"
+serde_derive = "1.0"
+
+# Web Stack
+futures = "0.1"
+actix = "0.5"
+actix-web = "0.6" \ No newline at end of file