aboutsummaryrefslogtreecommitdiff
path: root/overlays/staging/nodemcu-uploader/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/staging/nodemcu-uploader/default.nix')
-rw-r--r--overlays/staging/nodemcu-uploader/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/overlays/staging/nodemcu-uploader/default.nix b/overlays/staging/nodemcu-uploader/default.nix
new file mode 100644
index 00000000000..43176a9c890
--- /dev/null
+++ b/overlays/staging/nodemcu-uploader/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, python2, python2Packages, ... }:
+
+python2.pkgs.buildPythonApplication rec {
+ pname = "nodemcu-uploader";
+ version = "0.4.3";
+
+ src = python2.pkgs.fetchPypi {
+ inherit pname version;
+ sha256 = "13nlc2gr85pw7kcfirzi3k8rqybmdwhsxnndixvayis1fm80bsrf";
+ };
+
+ propagatedBuildInputs = with python2.pkgs; [ pyserial wrapt ];
+
+ doCheck = false;
+
+ meta = with stdenv.lib; {
+ description = "Lalalala";
+ homepage = https://www.foo.org;
+ license = licenses.mit;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ spacekookie ];
+ };
+}