aboutsummaryrefslogtreecommitdiff
path: root/overlays/kookie/invoice/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/kookie/invoice/default.nix')
-rw-r--r--overlays/kookie/invoice/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/overlays/kookie/invoice/default.nix b/overlays/kookie/invoice/default.nix
new file mode 100644
index 00000000000..25c0fbb1ddb
--- /dev/null
+++ b/overlays/kookie/invoice/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, makeWrapper, coreutils, findutils, gawk, pandoc, gnumake, texlive }:
+
+stdenv.mkDerivation {
+ pname = "invoice";
+ version = "0.1.0";
+ src = ./.;
+
+ nativeBuildInputs = [ makeWrapper ];
+
+ installPhase = ''
+ mkdir -p $out/{bin,share}
+ cp invoice.sh $out/bin/invoice
+ cp template.tex $out/share/
+
+ wrapProgram $out/bin/invoice \
+ --set PATH $out/bin:${stdenv.lib.makeBinPath
+ [ coreutils findutils gawk gnumake pandoc texlive.combined.scheme-full ]} \
+ --set TEMPLATE_FILE $out/share/template.tex
+ '';
+
+
+ meta = with stdenv.lib; {
+ description = "Generate dynamic invoices based on yaml descriptors";
+ homepage = "https://git.sr.ht/~spacekookie/kookiepkgs/";
+ license = licenses.gpl3;
+ };
+}
+