aboutsummaryrefslogtreecommitdiff
path: root/overlays/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
new file mode 100644
index 00000000000..c3dfd293116
--- /dev/null
+++ b/overlays/default.nix
@@ -0,0 +1,31 @@
+/* Overlays in LIBKOOKIE are split into three parts
+ *
+ * patches: upstream but with cool stuff
+ * staging: things that might become upstream
+ * kookie: scripts and utils that won't leave LIBKOOKIE
+ */
+
+self: super:
+
+with super; {
+
+ barrel-blog = callPackage ./kookie/barrel-blog { };
+
+ invoice = callPackage ./kookie/invoice { };
+
+ spacekookie-de = callPackage ./kookie/spacekookie-de { };
+
+} // {
+
+ nodemcu-uploader = callPackage ./staging/nodemcu-uploader { };
+
+ pleroma = callPackage ./staging/pleroma { };
+
+} // {
+
+ emacs-ergoemacs-mode = callPackage ./patches/emacs-ergoemacs-mode { };
+
+ htop = callPackage ./patches/htop { };
+
+ neomutt = callPackages ./patches/neomutt { };
+}