aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/quake3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/quake3.nix')
-rw-r--r--nixos/tests/quake3.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/tests/quake3.nix b/nixos/tests/quake3.nix
index d3e59a32373..4253ce4a867 100644
--- a/nixos/tests/quake3.nix
+++ b/nixos/tests/quake3.nix
@@ -12,9 +12,9 @@ let
# Only allow the demo data to be used (only if it's unfreeRedistributable).
unfreePredicate = pkg: with pkgs.lib; let
- allowDrvPredicates = [ "quake3-demo" "quake3-pointrelease" ];
+ allowPackageNames = [ "quake3-demodata" "quake3-pointrelease" ];
allowLicenses = [ pkgs.lib.licenses.unfreeRedistributable ];
- in any (flip hasPrefix pkg.name) allowDrvPredicates &&
+ in elem pkg.pname allowPackageNames &&
elem (pkg.meta.license or null) allowLicenses;
in