aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/hydra/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/hydra/default.nix')
-rw-r--r--nixos/tests/hydra/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos/tests/hydra/default.nix b/nixos/tests/hydra/default.nix
index f99b367ac9b..76000450921 100644
--- a/nixos/tests/hydra/default.nix
+++ b/nixos/tests/hydra/default.nix
@@ -8,8 +8,10 @@ let
trivialJob = pkgs.writeTextDir "trivial.nix" ''
{ trivial = builtins.derivation {
name = "trivial";
- system = "x86_64-linux";
+ system = "${system}";
builder = "/bin/sh";
+ allowSubstitutes = false;
+ preferLocalBuild = true;
args = ["-c" "echo success > $out; exit 0"];
};
}
@@ -57,7 +59,7 @@ let
nix = {
buildMachines = [{
hostName = "localhost";
- systems = [ "x86_64-linux" ];
+ systems = [ system ];
}];
binaryCaches = [];