aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/ceph.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/tests/ceph.nix')
-rw-r--r--nixos/tests/ceph.nix52
1 files changed, 37 insertions, 15 deletions
diff --git a/nixos/tests/ceph.nix b/nixos/tests/ceph.nix
index 8722ea33ec5..0706b68075c 100644
--- a/nixos/tests/ceph.nix
+++ b/nixos/tests/ceph.nix
@@ -1,4 +1,4 @@
-import ./make-test.nix ({pkgs, ...}: {
+import ./make-test.nix ({pkgs, lib, ...}: {
name = "All-in-one-basic-ceph-cluster";
meta = with pkgs.stdenv.lib.maintainers; {
maintainers = [ lejonet ];
@@ -7,6 +7,7 @@ import ./make-test.nix ({pkgs, ...}: {
nodes = {
aio = { pkgs, ... }: {
virtualisation = {
+ memorySize = 1536;
emptyDiskImages = [ 20480 20480 ];
vlans = [ 1 ];
};
@@ -24,9 +25,6 @@ import ./make-test.nix ({pkgs, ...}: {
ceph
xfsprogs
];
- nixpkgs.config.packageOverrides = super: {
- ceph = super.ceph.override({ nss = super.nss; libxfs = super.libxfs; libaio = super.libaio; jemalloc = super.jemalloc; });
- };
boot.kernelModules = [ "xfs" ];
@@ -51,6 +49,9 @@ import ./make-test.nix ({pkgs, ...}: {
enable = true;
daemons = [ "0" "1" ];
};
+
+ # So that we don't have to battle systemd when bootstraping
+ systemd.targets.ceph.wantedBy = lib.mkForce [];
};
};
@@ -61,24 +62,26 @@ import ./make-test.nix ({pkgs, ...}: {
# Create the ceph-related directories
$aio->mustSucceed(
- "mkdir -p /var/lib/ceph/mgr/ceph-aio/",
- "mkdir -p /var/lib/ceph/mon/ceph-aio/",
- "mkdir -p /var/lib/ceph/osd/ceph-{0..1}/",
- "chown ceph:ceph -R /var/lib/ceph/"
+ "mkdir -p /var/lib/ceph/mgr/ceph-aio",
+ "mkdir -p /var/lib/ceph/mon/ceph-aio",
+ "mkdir -p /var/lib/ceph/osd/ceph-{0,1}",
+ "chown ceph:ceph -R /var/lib/ceph/",
+ "mkdir -p /etc/ceph",
+ "chown ceph:ceph -R /etc/ceph"
);
# Bootstrap ceph-mon daemon
$aio->mustSucceed(
- "mkdir -p /var/lib/ceph/bootstrap-osd && chown ceph:ceph /var/lib/ceph/bootstrap-osd",
"sudo -u ceph ceph-authtool --create-keyring /tmp/ceph.mon.keyring --gen-key -n mon. --cap mon 'allow *'",
- "ceph-authtool --create-keyring /etc/ceph/ceph.client.admin.keyring --gen-key -n client.admin --set-uid=0 --cap mon 'allow *' --cap osd 'allow *' --cap mds 'allow *' --cap mgr 'allow *'",
- "ceph-authtool /tmp/ceph.mon.keyring --import-keyring /etc/ceph/ceph.client.admin.keyring",
- "monmaptool --create --add aio 192.168.1.1 --fsid 066ae264-2a5d-4729-8001-6ad265f50b03 /tmp/monmap",
+ "sudo -u ceph ceph-authtool --create-keyring /etc/ceph/ceph.client.admin.keyring --gen-key -n client.admin --cap mon 'allow *' --cap osd 'allow *' --cap mds 'allow *' --cap mgr 'allow *'",
+ "sudo -u ceph ceph-authtool /tmp/ceph.mon.keyring --import-keyring /etc/ceph/ceph.client.admin.keyring",
+ "monmaptool --create --add aio 192.168.1.1 --fsid 066ae264-2a5d-4729-8001-6ad265f50b03 /tmp/monmap",
"sudo -u ceph ceph-mon --mkfs -i aio --monmap /tmp/monmap --keyring /tmp/ceph.mon.keyring",
- "touch /var/lib/ceph/mon/ceph-aio/done",
+ "sudo -u ceph touch /var/lib/ceph/mon/ceph-aio/done",
"systemctl start ceph-mon-aio"
);
$aio->waitForUnit("ceph-mon-aio");
+ $aio->mustSucceed("ceph mon enable-msgr2");
# Can't check ceph status until a mon is up
$aio->succeed("ceph -s | grep 'mon: 1 daemons'");
@@ -90,6 +93,7 @@ import ./make-test.nix ({pkgs, ...}: {
);
$aio->waitForUnit("ceph-mgr-aio");
$aio->waitUntilSucceeds("ceph -s | grep 'quorum aio'");
+ $aio->waitUntilSucceeds("ceph -s | grep 'mgr: aio(active,'");
# Bootstrap both OSDs
$aio->mustSucceed(
@@ -112,8 +116,8 @@ import ./make-test.nix ({pkgs, ...}: {
"systemctl start ceph-osd-1"
);
- $aio->waitUntilSucceeds("ceph osd stat | grep '2 osds: 2 up, 2 in'");
- $aio->waitUntilSucceeds("ceph -s | grep 'mgr: aio(active)'");
+ $aio->waitUntilSucceeds("ceph osd stat | grep -e '2 osds: 2 up[^,]*, 2 in'");
+ $aio->waitUntilSucceeds("ceph -s | grep 'mgr: aio(active,'");
$aio->waitUntilSucceeds("ceph -s | grep 'HEALTH_OK'");
$aio->mustSucceed(
@@ -135,5 +139,23 @@ import ./make-test.nix ({pkgs, ...}: {
"ceph osd pool ls | grep 'aio-test'",
"ceph osd pool delete aio-other-test aio-other-test --yes-i-really-really-mean-it"
);
+
+ # As we disable the target in the config, we still want to test that it works as intended
+ $aio->mustSucceed(
+ "systemctl stop ceph-osd-0",
+ "systemctl stop ceph-osd-1",
+ "systemctl stop ceph-mgr-aio",
+ "systemctl stop ceph-mon-aio"
+ );
+ $aio->succeed("systemctl start ceph.target");
+ $aio->waitForUnit("ceph-mon-aio");
+ $aio->waitForUnit("ceph-mgr-aio");
+ $aio->waitForUnit("ceph-osd-0");
+ $aio->waitForUnit("ceph-osd-1");
+ $aio->succeed("ceph -s | grep 'mon: 1 daemons'");
+ $aio->waitUntilSucceeds("ceph -s | grep 'quorum aio'");
+ $aio->waitUntilSucceeds("ceph osd stat | grep -e '2 osds: 2 up[^,]*, 2 in'");
+ $aio->waitUntilSucceeds("ceph -s | grep 'mgr: aio(active,'");
+ $aio->waitUntilSucceeds("ceph -s | grep 'HEALTH_OK'");
'';
})