aboutsummaryrefslogtreecommitdiff
path: root/modules/xcursor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/xcursor.nix')
-rw-r--r--modules/xcursor.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/modules/xcursor.nix b/modules/xcursor.nix
index bb8af9b7833..171586028cd 100644
--- a/modules/xcursor.nix
+++ b/modules/xcursor.nix
@@ -26,6 +26,13 @@ let
example = 64;
description = "The cursor size.";
};
+
+ defaultCursor = mkOption {
+ type = types.str;
+ default = "left_ptr";
+ example = "X_cursor";
+ description = "The default cursor file to use within the package.";
+ };
};
};
@@ -54,7 +61,7 @@ in
home.packages = [cfg.package];
xsession.initExtra = ''
- ${pkgs.xorg.xsetroot}/bin/xsetroot -xcf ${cfg.package}/share/icons/${cfg.name}/cursors/X_cursor ${toString cfg.size}
+ ${pkgs.xorg.xsetroot}/bin/xsetroot -xcf ${cfg.package}/share/icons/${cfg.name}/cursors/${cfg.defaultCursor} ${toString cfg.size}
'';
xresources.properties = {