aboutsummaryrefslogtreecommitdiff
path: root/modules/workstation/graphics/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/workstation/graphics/default.nix')
-rw-r--r--modules/workstation/graphics/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/workstation/graphics/default.nix b/modules/workstation/graphics/default.nix
new file mode 100644
index 00000000000..5f902759d8f
--- /dev/null
+++ b/modules/workstation/graphics/default.nix
@@ -0,0 +1,31 @@
+{ pkgs, ... }:
+
+{
+ services.xserver = {
+ enable = true;
+ desktopManager = {
+ default = "xfce";
+ xfce = {
+ enable = true;
+ noDesktop = true;
+ enableXfwm = false;
+ };
+ };
+ windowManager.i3.enable = true;
+
+ videoDrivers = [ "intel" ];
+ deviceSection = ''
+ Option "DRI" "2"
+ Option "TearFree" "true"
+ '';
+ useGlamor = true;
+ };
+
+ home-manager.users.spacekookie = { ... }: {
+ imports = [
+ ./i3
+ ./browser.nix
+ ./fun.nix
+ ];
+ };
+}