aboutsummaryrefslogtreecommitdiff
path: root/modules/workstation/devel/java/lwjgl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/workstation/devel/java/lwjgl.nix')
-rw-r--r--modules/workstation/devel/java/lwjgl.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/workstation/devel/java/lwjgl.nix b/modules/workstation/devel/java/lwjgl.nix
new file mode 100644
index 00000000000..77ab765f207
--- /dev/null
+++ b/modules/workstation/devel/java/lwjgl.nix
@@ -0,0 +1,33 @@
+{ stdenv, pkgs, ... }:
+
+with pkgs;
+stdenv.mkDerivation rec {
+ name = "lwjgl-${version}";
+ version = "2.9.2";
+
+ src = fetchurl {
+ url = "https://github.com/LWJGL/lwjgl/archive/lwjgl${version}.tar.gz";
+ sha256 = "1m396ply3kspym3r00s1rbk77irn2f9vgr76xsy7272k649y3wky";
+ };
+
+ buildInputs = with xorg; [ ant openjdk gcc libX11 libXt libXcursor
+ libXxf86vm libXrandr libXext ];
+
+ buildPhase = "mkdir -p bin && ant generate-all && ant compile && ant compile_native";
+
+ installPhase = ''
+ mkdir -p $out/lib
+ cp bin/lwjgl/*.so $out/lib
+ '';
+
+ meta = with stdenv.lib; {
+ description = "The Lightweight Java Game Library";
+ longDescription = ''
+ LWJGL is a Java library that enables cross-platform access to popular native APIs useful in the development of graphics (OpenGL), audio (OpenAL) and parallel computing (OpenCL) applications. This access is direct and high-performance, yet also wrapped in a type-safe and user-friendly layer, appropriate for the Java ecosystem.
+ '';
+ homepage = http://legacy.lwjgl.org/;
+ license = licenses.bsd3;
+ maintainers = with maintainers; [ pmiddend ];
+ platforms = platforms.linux;
+ };
+}