aboutsummaryrefslogtreecommitdiff
path: root/modules/workstation/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/workstation/default.nix')
-rw-r--r--modules/workstation/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/modules/workstation/default.nix b/modules/workstation/default.nix
new file mode 100644
index 00000000000..2b9543dc5f5
--- /dev/null
+++ b/modules/workstation/default.nix
@@ -0,0 +1,34 @@
+/* GENERAL WORKSTATION CONFIGURATION
+ *
+ * A workstation is a computer with it's own screen,
+ * keyboard and (sometimes) mouse. It can also sometimes
+ * play music or print (provided the correct satanic
+ * sacrifice was precured first).
+ *
+ * Some of the modules included by this file depend on
+ * root access on a system (nixos-rebuild), while some
+ * can be operated entirely in userspace.
+ */
+
+{ pkgs, home-manager, ... }:
+
+{
+ home-manager.users.spacekookie = { ... }: {
+ imports = [
+ ./chat
+ ./devel
+ ./emacs
+ ./git
+ ./pass
+ ];
+ };
+
+ imports = [
+ ./graphics
+ ./hardware
+ ./mail
+ ./networking
+ ./sound
+ ./syncthing
+ ];
+}