aboutsummaryrefslogtreecommitdiff
path: root/modules/services/udiskie.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/udiskie.nix')
-rw-r--r--modules/services/udiskie.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/modules/services/udiskie.nix b/modules/services/udiskie.nix
index 5155b37cd1c..2976a631892 100644
--- a/modules/services/udiskie.nix
+++ b/modules/services/udiskie.nix
@@ -13,6 +13,7 @@ let
(if cfg.notify then "n" else "N")
({ always = "t"; auto = "s"; never = "T"; }.${cfg.tray})
]
+ ++ optional cfg.sni "--appindicator"
);
in
@@ -36,6 +37,12 @@ in
description = "Whether to show pop-up notifications.";
};
+ sni = mkOption {
+ type = types.bool;
+ default = false;
+ description = "Whether to enable sni (appindicator) support.";
+ };
+
tray = mkOption {
type = types.enum [ "always" "auto" "never" ];
default = "auto";