aboutsummaryrefslogtreecommitdiff
path: root/modules/services/imapnotify-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/services/imapnotify-accounts.nix')
-rw-r--r--modules/services/imapnotify-accounts.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/modules/services/imapnotify-accounts.nix b/modules/services/imapnotify-accounts.nix
index 1c780bf28c3..94bdce5dfb4 100644
--- a/modules/services/imapnotify-accounts.nix
+++ b/modules/services/imapnotify-accounts.nix
@@ -16,13 +16,16 @@ with lib;
onNotifyPost = mkOption {
type = with types; either str (attrsOf str);
default = "";
- example = { mail = "\${pkgs.notmuch}/bin/notmuch new && \${pkgs.libnotify}/bin/notify-send 'New mail arrived'"; };
+ example = {
+ mail =
+ "\${pkgs.notmuch}/bin/notmuch new && \${pkgs.libnotify}/bin/notify-send 'New mail arrived'";
+ };
description = "Shell commands to run after onNotify event.";
};
boxes = mkOption {
type = types.listOf types.str;
- default = [];
+ default = [ ];
example = [ "Inbox" "[Gmail]/MyLabel" ];
description = "IMAP folders to watch.";
};