aboutsummaryrefslogtreecommitdiff
path: root/lib/meta.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/meta.nix')
-rw-r--r--lib/meta.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/lib/meta.nix b/lib/meta.nix
index 07b1710fff7..199030c103a 100644
--- a/lib/meta.nix
+++ b/lib/meta.nix
@@ -67,4 +67,23 @@ rec {
*/
hiPrioSet = set: mapDerivationAttrset hiPrio set;
+
+ /* Check to see if a platform is matched by the given `meta.platforms`
+ element.
+
+ A `meta.platform` pattern is either
+
+ 1. (legacy) a system string.
+
+ 2. (modern) a pattern for the platform `parsed` field.
+
+ We can inject these into a patten for the whole of a structured platform,
+ and then match that.
+ */
+ platformMatch = platform: elem: let
+ pattern =
+ if builtins.isString elem
+ then { system = elem; }
+ else { parsed = elem; };
+ in lib.matchAttrs pattern platform;
}