aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/services/sxhkd/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/services/sxhkd/configuration.nix')
-rw-r--r--home-manager/tests/modules/services/sxhkd/configuration.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/home-manager/tests/modules/services/sxhkd/configuration.nix b/home-manager/tests/modules/services/sxhkd/configuration.nix
new file mode 100644
index 00000000000..992c4b18a94
--- /dev/null
+++ b/home-manager/tests/modules/services/sxhkd/configuration.nix
@@ -0,0 +1,30 @@
+{ config, ... }: {
+ config = {
+ services.sxhkd = {
+ enable = true;
+
+ keybindings = {
+ "super + a" = "run command a";
+ "super + b" = null;
+ "super + Shift + b" = "run command b";
+ };
+
+ extraConfig = ''
+ super + c
+ call command c
+
+ # comment
+ super + d
+ call command d
+ '';
+ };
+
+ nmt.script = ''
+ local sxhkdrc=home-files/.config/sxhkd/sxhkdrc
+
+ assertFileExists $sxhkdrc
+
+ assertFileContent $sxhkdrc ${./sxhkdrc}
+ '';
+ };
+}