aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix')
-rw-r--r--home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix b/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
new file mode 100644
index 00000000000..2558a25832f
--- /dev/null
+++ b/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
@@ -0,0 +1,33 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ config = {
+ programs.rofi = {
+ enable = true;
+ theme = "foo";
+ colors = {
+ window = {
+ background = "background";
+ border = "border";
+ separator = "separator";
+ };
+ rows = {
+ };
+ };
+ };
+
+ home.file.result.text =
+ builtins.toJSON
+ (map (a: a.message)
+ (filter (a: !a.assertion)
+ config.assertions));
+
+ nmt.script = ''
+ assertFileContent \
+ home-files/result \
+ ${./assert-on-both-theme-and-colors-expected.json}
+ '';
+ };
+}