aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/getmail/getmail.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/programs/getmail/getmail.nix')
-rw-r--r--home-manager/tests/modules/programs/getmail/getmail.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/home-manager/tests/modules/programs/getmail/getmail.nix b/home-manager/tests/modules/programs/getmail/getmail.nix
new file mode 100644
index 00000000000..b0d979c4672
--- /dev/null
+++ b/home-manager/tests/modules/programs/getmail/getmail.nix
@@ -0,0 +1,28 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ imports = [ ../../accounts/email-test-accounts.nix ];
+
+ config = {
+ accounts.email.accounts = {
+ "hm@example.com" = {
+ getmail = {
+ enable = true;
+ mailboxes = [ "INBOX" "Sent" "Work" ];
+ destinationCommand = "/bin/maildrop";
+ delete = false;
+ };
+ imap.port = 993;
+ };
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.getmail/getmailhm@example.com
+ assertFileContent home-files/.getmail/getmailhm@example.com ${
+ ./getmail-expected.conf
+ }
+ '';
+ };
+}