aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix')
-rw-r--r--home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
new file mode 100644
index 00000000000..90038cfd034
--- /dev/null
+++ b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ config = {
+ home.stateVersion = "19.09";
+
+ home.keyboard = { options = [ "ctrl:nocaps" "altwin:no_win" ]; };
+
+ xsession = {
+ enable = true;
+ windowManager.command = "window manager command";
+ importedVariables = [ "EXTRA_IMPORTED_VARIABLE" ];
+ initExtra = "init extra commands";
+ profileExtra = "profile extra commands";
+ };
+
+ nixpkgs.overlays = [
+ (self: super: {
+ xorg = super.xorg // {
+ setxkbmap = super.xorg.setxkbmap // { outPath = "@setxkbmap@"; };
+ };
+ })
+ ];
+
+ nmt.script = ''
+ assertFileExists home-files/.config/systemd/user/setxkbmap.service
+ assertFileContent \
+ home-files/.config/systemd/user/setxkbmap.service \
+ ${./keyboard-without-layout-expected.service}
+ '';
+ };
+}