aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/tahoe-lafs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/services/tahoe-lafs.nix')
-rw-r--r--home-manager/modules/services/tahoe-lafs.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/home-manager/modules/services/tahoe-lafs.nix b/home-manager/modules/services/tahoe-lafs.nix
new file mode 100644
index 00000000000..bb7be8d7db9
--- /dev/null
+++ b/home-manager/modules/services/tahoe-lafs.nix
@@ -0,0 +1,25 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ meta.maintainers = [ maintainers.rycee ];
+
+ options = {
+ services.tahoe-lafs = {
+ enable = mkEnableOption "Tahoe-LAFS";
+ };
+ };
+
+ config = mkIf config.services.tahoe-lafs.enable {
+ systemd.user.services.tahoe-lafs = {
+ Unit = {
+ Description = "Tahoe-LAFS";
+ };
+
+ Service = {
+ ExecStart = "${pkgs.tahoelafs}/bin/tahoe run -C %h/.tahoe";
+ };
+ };
+ };
+}