aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/offlineimap-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/programs/offlineimap-accounts.nix')
-rw-r--r--home-manager/modules/programs/offlineimap-accounts.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/home-manager/modules/programs/offlineimap-accounts.nix b/home-manager/modules/programs/offlineimap-accounts.nix
new file mode 100644
index 00000000000..afc7a019972
--- /dev/null
+++ b/home-manager/modules/programs/offlineimap-accounts.nix
@@ -0,0 +1,51 @@
+{ config, lib, ... }:
+
+with lib;
+
+let
+
+ extraConfigType = with types; attrsOf (either (either str int) bool);
+
+in {
+ options.offlineimap = {
+ enable = mkEnableOption "OfflineIMAP";
+
+ extraConfig.account = mkOption {
+ type = extraConfigType;
+ default = { };
+ example = { autorefresh = 20; };
+ description = ''
+ Extra configuration options to add to the account section.
+ '';
+ };
+
+ extraConfig.local = mkOption {
+ type = extraConfigType;
+ default = { };
+ example = { sync_deletes = true; };
+ description = ''
+ Extra configuration options to add to the local account
+ section.
+ '';
+ };
+
+ extraConfig.remote = mkOption {
+ type = extraConfigType;
+ default = { };
+ example = {
+ maxconnections = 2;
+ expunge = false;
+ };
+ description = ''
+ Extra configuration options to add to the remote account
+ section.
+ '';
+ };
+
+ postSyncHookCommand = mkOption {
+ type = types.lines;
+ default = "";
+ description = "Command to run after fetching new mails.";
+ };
+ };
+}