aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/getmail-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/programs/getmail-accounts.nix')
-rw-r--r--home-manager/modules/programs/getmail-accounts.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/home-manager/modules/programs/getmail-accounts.nix b/home-manager/modules/programs/getmail-accounts.nix
new file mode 100644
index 00000000000..24eb4fb588a
--- /dev/null
+++ b/home-manager/modules/programs/getmail-accounts.nix
@@ -0,0 +1,49 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ options.getmail = {
+ enable = mkEnableOption "the getmail mail retriever for this account";
+
+ destinationCommand = mkOption {
+ type = types.nullOr types.str;
+ default = null;
+ example = "\${pkgs.maildrop}/bin/maildrop";
+ description = ''
+ Specify a command delivering the incoming mail to your maildir.
+ '';
+ };
+
+ mailboxes = mkOption {
+ type = types.nonEmptyListOf types.str;
+ default = [ ];
+ example = [ "INBOX" "INBOX.spam" ];
+ description = ''
+ A non-empty list of mailboxes. To download all mail you can
+ use the <literal>ALL</literal> mailbox.
+ '';
+ };
+
+ delete = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Enable if you want to delete read messages from the server. Most
+ users should either enable <literal>delete</literal> or disable
+ <literal>readAll</literal>.
+ '';
+ };
+
+ readAll = mkOption {
+ type = types.bool;
+ default = true;
+ description = ''
+ Enable if you want to fetch all, even the read messages from the
+ server. Most users should either enable <literal>delete</literal> or
+ disable <literal>readAll</literal>.
+ '';
+ };
+
+ };
+}