aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/misc/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/modules/misc/lib.nix')
-rw-r--r--home-manager/modules/misc/lib.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/home-manager/modules/misc/lib.nix b/home-manager/modules/misc/lib.nix
new file mode 100644
index 00000000000..13c00dc59a6
--- /dev/null
+++ b/home-manager/modules/misc/lib.nix
@@ -0,0 +1,14 @@
+{ lib, ... }:
+
+{
+ options = {
+ lib = lib.mkOption {
+ type = lib.types.attrsOf lib.types.attrs;
+ default = { };
+ description = ''
+ This option allows modules to define helper functions,
+ constants, etc.
+ '';
+ };
+ };
+}