aboutsummaryrefslogtreecommitdiff
path: root/tests/modules/programs/git/git.nix
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2020-07-20 10:03:40 -0500
committerGitHub <noreply@github.com>2020-07-20 17:03:40 +0200
commit4bd0ca2cd793b3f057d114bd6a3183419f52ca49 (patch)
tree317c94b585846fb978c09157e70a67ebb9d5cfee /tests/modules/programs/git/git.nix
parent5c639ff68abf0f16f2e63fb3f8aca016d54c7d10 (diff)
git: configure delta through [delta] git section (#1371)
this breaks backwards compatibility (now accepts a dict instead of a list) so please update programs.git.delta.options accordingly.
Diffstat (limited to '')
-rw-r--r--tests/modules/programs/git/git.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/modules/programs/git/git.nix b/tests/modules/programs/git/git.nix
index 54e3c79b43d..feefff54b61 100644
--- a/tests/modules/programs/git/git.nix
+++ b/tests/modules/programs/git/git.nix
@@ -60,7 +60,15 @@ in {
lfs.enable = true;
delta = {
enable = true;
- options = [ "--dark" ];
+ options = {
+ features = "decorations";
+ whitespace-error-style = "22 reverse";
+ decorations = {
+ commit-decoration-style = "bold yellow box ul";
+ file-style = "bold yellow ul";
+ file-decoration-style = "none";
+ };
+ };
};
}