aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorVladimír Čunát <v@cunat.cz>2019-05-26 09:48:55 +0200
committerVladimír Čunát <v@cunat.cz>2019-05-26 09:48:55 +0200
commitb4ae841b238a0663b069df1de49ae9ef7c8d76ba (patch)
tree7b5bc3e2f529ade9240b4e07d5868ac57c54f613 /pkgs/stdenv
parente775638efdd1a1fbefaf0192de169671f61515d7 (diff)
parentb2ab860db3996f28236c9ed92f08831dd6c6c5ef (diff)
Merge branch 'staging-next' into staging
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/adapters.nix2
-rw-r--r--pkgs/stdenv/darwin/default.nix2
-rw-r--r--pkgs/stdenv/linux/default.nix2
3 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/stdenv/adapters.nix b/pkgs/stdenv/adapters.nix
index 2b1f166f8c3..8ece43f87b0 100644
--- a/pkgs/stdenv/adapters.nix
+++ b/pkgs/stdenv/adapters.nix
@@ -129,7 +129,7 @@ rec {
with the following function:
isFree = license: with builtins;
- if isNull license then true
+ if license == null then true
else if isList license then lib.all isFree license
else license != "non-free" && license != "unfree";
diff --git a/pkgs/stdenv/darwin/default.nix b/pkgs/stdenv/darwin/default.nix
index 3c3917c827e..20062bba8ee 100644
--- a/pkgs/stdenv/darwin/default.nix
+++ b/pkgs/stdenv/darwin/default.nix
@@ -81,7 +81,7 @@ in rec {
bintools = { name = "${name}-binutils"; outPath = bootstrapTools; };
};
- cc = if isNull last then "/dev/null" else import ../../build-support/cc-wrapper {
+ cc = if last == null then "/dev/null" else import ../../build-support/cc-wrapper {
inherit shell;
inherit (last) stdenvNoCC;
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 2bccd620436..390c7f1123e 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -96,7 +96,7 @@ let
inherit system;
};
- cc = if isNull prevStage.gcc-unwrapped
+ cc = if prevStage.gcc-unwrapped == null
then null
else lib.makeOverridable (import ../../build-support/cc-wrapper) {
name = "${name}-gcc-wrapper";