aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
authorvolth <volth@webmaster.ms>2019-04-21 20:05:13 +0000
committerGitHub <noreply@github.com>2019-04-21 20:05:13 +0000
commitb0193379e5eaa2d1f9b4c4dba3552641e396d3d9 (patch)
tree0599de0c9e5010330d5c43f69e40224beed576bc /pkgs/stdenv
parentb1c3581b467b3376dede1132b9d9b88a20ac7cf2 (diff)
make-derivation.nix: minor
it seems to change nothing (.platform is always there), just to be consisted with the style of other checks
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/make-derivation.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/stdenv/generic/make-derivation.nix b/pkgs/stdenv/generic/make-derivation.nix
index cb50fdf7313..34d48e8cf33 100644
--- a/pkgs/stdenv/generic/make-derivation.nix
+++ b/pkgs/stdenv/generic/make-derivation.nix
@@ -253,7 +253,7 @@ in rec {
enableParallelChecking = attrs.enableParallelChecking or true;
} // lib.optionalAttrs (hardeningDisable != [] || hardeningEnable != []) {
NIX_HARDENING_ENABLE = enabledHardeningOptions;
- } // lib.optionalAttrs (stdenv.hostPlatform.isx86_64 && stdenv.hostPlatform.platform ? gcc.arch) {
+ } // lib.optionalAttrs (stdenv.hostPlatform.isx86_64 && stdenv.hostPlatform ? platform.gcc.arch) {
requiredSystemFeatures = attrs.requiredSystemFeatures or [] ++ [ "gccarch-${stdenv.hostPlatform.platform.gcc.arch}" ];
} // lib.optionalAttrs (stdenv.buildPlatform.isDarwin) {
inherit __darwinAllowLocalNetworking;