aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2019-08-22 16:47:25 +0200
committerRobin Gloster <mail@glob.in>2019-08-22 16:47:25 +0200
commit0f4256a2f81833118211283ec8970789405273b4 (patch)
treeb3b9621d0649a3af4c15cbdefa31b7d6d91bcab7 /pkgs/shells
parentc89e5439a168cc2c93c11da7c01563695bba0d0b (diff)
powershell: pint to openssl 1.0.2
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/powershell/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/shells/powershell/default.nix b/pkgs/shells/powershell/default.nix
index a434ef7e4fb..3a6eb6378f0 100644
--- a/pkgs/shells/powershell/default.nix
+++ b/pkgs/shells/powershell/default.nix
@@ -1,5 +1,5 @@
{ stdenv, autoPatchelfHook, fetchzip, libunwind, libuuid, icu, curl
-, darwin, makeWrapper, less, openssl, pam, lttng-ust }:
+, darwin, makeWrapper, less, openssl_1_0_2, pam, lttng-ust }:
let platformString = if stdenv.isDarwin then "osx"
else if stdenv.isLinux then "linux"
@@ -10,7 +10,7 @@ let platformString = if stdenv.isDarwin then "osx"
platformLdLibraryPath = if stdenv.isDarwin then "DYLD_FALLBACK_LIBRARY_PATH"
else if stdenv.isLinux then "LD_LIBRARY_PATH"
else throw "unsupported platform";
- libraries = [ libunwind libuuid icu curl openssl ] ++
+ libraries = [ libunwind libuuid icu curl openssl_1_0_2 ] ++
(if stdenv.isLinux then [ pam lttng-ust ] else [ darwin.Libsystem ]);
in
stdenv.mkDerivation rec {