aboutsummaryrefslogtreecommitdiff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2019-06-29 12:14:42 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2019-06-29 12:14:42 +0200
commit02e8a36df1c33253822a945ab6290960edf7d082 (patch)
tree44665517221ba4e917cc3aab82cb4ccc86d34529 /pkgs/shells
parent1ab2e927a6398822e9888347237b2a178326258e (diff)
zsh-you-should-use: init at 1.1.0
Simple zsh plugin that reminds you to use existing aliases. With `oh-my-zsh` it can be installed like this: ``` { programs.zsh.ohMyZsh = { customPkgs = [ pkgs.zsh-you-should-use ]; plugins = [ "you-should-use" ]; }; } ```
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/zsh-you-should-use/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/shells/zsh/zsh-you-should-use/default.nix b/pkgs/shells/zsh/zsh-you-should-use/default.nix
new file mode 100644
index 00000000000..c44483d3744
--- /dev/null
+++ b/pkgs/shells/zsh/zsh-you-should-use/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+ pname = "zsh-you-should-use";
+ version = "1.1.0";
+
+ src = fetchFromGitHub {
+ owner = "MichaelAquilina";
+ repo = pname;
+ rev = version;
+ sha256 = "0fig5ralagi5jajk7gdm52jvwql17qk9cd6j98qsndvckb26a753";
+ };
+
+ dontBuild = true;
+
+ installPhase = ''
+ install -D you-should-use.plugin.zsh $out/share/zsh/plugins/you-should-use/you-should-use.plugin.zsh
+ '';
+
+ meta = with stdenv.lib; {
+ homepage = https://github.com/MichaelAquilina/zsh-you-should-use;
+ license = licenses.gpl3;
+ description = "ZSH plugin that reminds you to use existing aliases for commands you just typed";
+ maintainers = with maintainers; [ ma27 ];
+ };
+}