aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJan Hrnko <jan.hrnko@satoshilabs.com>2019-09-20 10:34:00 +0200
committerJan Hrnko <jan.hrnko@satoshilabs.com>2019-09-20 10:34:00 +0200
commita203ba2bf104697e9489d77791d3b3a5105efb81 (patch)
treebe6ae27959d9519d781cf82f3e7491501b153db0 /pkgs/servers
parenta7f002ac41dd4127e811df8bc4edfbb034aa2861 (diff)
prometheus-apcupsd-exporter: init at unstable-2019-03-14
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/prometheus/apcupsd-exporter.nix27
-rw-r--r--pkgs/servers/monitoring/prometheus/apcupsd-exporter_deps.nix93
2 files changed, 120 insertions, 0 deletions
diff --git a/pkgs/servers/monitoring/prometheus/apcupsd-exporter.nix b/pkgs/servers/monitoring/prometheus/apcupsd-exporter.nix
new file mode 100644
index 00000000000..c1d7f792830
--- /dev/null
+++ b/pkgs/servers/monitoring/prometheus/apcupsd-exporter.nix
@@ -0,0 +1,27 @@
+{ stdenv, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+ pname = "apcupsd-exporter";
+ version = "unstable-2019-03-14";
+
+ goPackagePath = "github.com/mdlayher/apcupsd_exporter";
+
+ goDeps = ./apcupsd-exporter_deps.nix;
+
+ src = fetchFromGitHub {
+ owner = "mdlayher";
+ repo = "apcupsd_exporter";
+ rev = "cbd49be";
+ sha256 = "1h5z295m9bddch5bc8fppn02b31h370yns6026a1d4ygfy3w46y0";
+ };
+
+ doCheck = true;
+
+ meta = with stdenv.lib; {
+ description = "Provides a Prometheus exporter for the apcupsd Network Information Server (NIS)";
+ homepage = "https://github.com/mdlayher/apcupsd_exporter";
+ license = licenses.mit;
+ maintainers = with maintainers; [ maintainers."1000101" ];
+ platforms = platforms.all;
+ };
+}
diff --git a/pkgs/servers/monitoring/prometheus/apcupsd-exporter_deps.nix b/pkgs/servers/monitoring/prometheus/apcupsd-exporter_deps.nix
new file mode 100644
index 00000000000..3950ae89bf2
--- /dev/null
+++ b/pkgs/servers/monitoring/prometheus/apcupsd-exporter_deps.nix
@@ -0,0 +1,93 @@
+# file generated from go.mod using vgo2nix (https://github.com/adisbladis/vgo2nix)
+[
+ {
+ goPackagePath = "github.com/beorn7/perks";
+ fetch = {
+ type = "git";
+ url = "https://github.com/beorn7/perks";
+ rev = "3a771d992973";
+ sha256 = "1l2lns4f5jabp61201sh88zf3b0q793w4zdgp9nll7mmfcxxjif3";
+ };
+ }
+ {
+ goPackagePath = "github.com/golang/protobuf";
+ fetch = {
+ type = "git";
+ url = "https://github.com/golang/protobuf";
+ rev = "v1.2.0";
+ sha256 = "0kf4b59rcbb1cchfny2dm9jyznp8ri2hsb14n8iak1q8986xa0ab";
+ };
+ }
+ {
+ goPackagePath = "github.com/matttproud/golang_protobuf_extensions";
+ fetch = {
+ type = "git";
+ url = "https://github.com/matttproud/golang_protobuf_extensions";
+ rev = "v1.0.1";
+ sha256 = "1d0c1isd2lk9pnfq2nk0aih356j30k3h1gi2w0ixsivi5csl7jya";
+ };
+ }
+ {
+ goPackagePath = "github.com/mdlayher/apcupsd";
+ fetch = {
+ type = "git";
+ url = "https://github.com/mdlayher/apcupsd";
+ rev = "eb3dd99a75fe";
+ sha256 = "0s1m6l4pnazqiymb8y89ajbxfl2cn0ahvhws10nvxvc4jjivlbbq";
+ };
+ }
+ {
+ goPackagePath = "github.com/prometheus/client_golang";
+ fetch = {
+ type = "git";
+ url = "https://github.com/prometheus/client_golang";
+ rev = "v0.9.2";
+ sha256 = "02b4yg6rfag0m3j0i39sillcm5xczwv8h133vn12yr8qw04cnigs";
+ };
+ }
+ {
+ goPackagePath = "github.com/prometheus/client_model";
+ fetch = {
+ type = "git";
+ url = "https://github.com/prometheus/client_model";
+ rev = "5c3871d89910";
+ sha256 = "04psf81l9fjcwascsys428v03fx4fi894h7fhrj2vvcz723q57k0";
+ };
+ }
+ {
+ goPackagePath = "github.com/prometheus/common";
+ fetch = {
+ type = "git";
+ url = "https://github.com/prometheus/common";
+ rev = "4724e9255275";
+ sha256 = "0pcx8hlnrxx5nnmpk786cn99rsgqk1jrd3c9f6fsx8qd8y5iwjy6";
+ };
+ }
+ {
+ goPackagePath = "github.com/prometheus/procfs";
+ fetch = {
+ type = "git";
+ url = "https://github.com/prometheus/procfs";
+ rev = "1dc9a6cbc91a";
+ sha256 = "1zlv1x30xp7z5c3vn5vp870v4bjim0zcidzc3mr2l3xhazc0svab";
+ };
+ }
+ {
+ goPackagePath = "golang.org/x/net";
+ fetch = {
+ type = "git";
+ url = "https://go.googlesource.com/net";
+ rev = "351d144fa1fc";
+ sha256 = "1c5x25qjyz83y92bq0lll5kmznyi3m02wd4c54scgf0866gy938k";
+ };
+ }
+ {
+ goPackagePath = "golang.org/x/sync";
+ fetch = {
+ type = "git";
+ url = "https://go.googlesource.com/sync";
+ rev = "42b317875d0f";
+ sha256 = "0mrjhk7al7yyh76x9flvxy4jm5jyqh2fxbxagpaazxn1xdgkaif3";
+ };
+ }
+]