aboutsummaryrefslogtreecommitdiff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2019-09-19 18:11:55 -0500
committerAustin Seipp <aseipp@pobox.com>2019-09-19 18:28:04 -0500
commit889537352b5e208017dad66dd51b3923b7f2d23f (patch)
treec2e8038faf08a0fd3583c43403c9b4db5c042218 /pkgs/servers
parent8dbca5e3ca41787b3af3d3695062577f3b855a21 (diff)
h2o: 2.2.6 -> 2.3.0-beta2, enable multi-output
This also lets us remove a hack for supporting LibreSSL 2.7, since we're now using 2.9 by default, anyway. Finally, use Ninja to run the CMake build instead of Make -- speeds things up for me by a few seconds. Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/h2o/default.nix31
1 files changed, 11 insertions, 20 deletions
diff --git a/pkgs/servers/http/h2o/default.nix b/pkgs/servers/http/h2o/default.nix
index 26c320499e5..a8de0d7e084 100644
--- a/pkgs/servers/http/h2o/default.nix
+++ b/pkgs/servers/http/h2o/default.nix
@@ -1,39 +1,30 @@
{ stdenv, fetchFromGitHub
-, pkgconfig, cmake
+, pkgconfig, cmake, ninja
, libressl, libuv, zlib
}:
-with builtins;
-
stdenv.mkDerivation rec {
- pname = "h2o";
- version = "2.2.6";
+ pname = "h2o";
+ version = "2.3.0-beta2";
src = fetchFromGitHub {
owner = "h2o";
repo = "h2o";
rev = "refs/tags/v${version}";
- sha256 = "0qni676wqvxx0sl0pw9j0ph7zf2krrzqc1zwj73mgpdnsr8rsib7";
+ sha256 = "0lwg5sfsr7fw7cfy0hrhadgixm35b5cgcvlhwhbk89j72y1bqi6n";
};
- # We have to fix up some function prototypes, because despite upstream h2o
- # issue #1705 (https://github.com/h2o/h2o/issues/1706), libressl 2.7+ doesn't
- # seem to work
- patchPhase = ''
- substituteInPlace ./deps/neverbleed/neverbleed.c \
- --replace 'static void RSA_' 'void RSA_' \
- --replace 'static int RSA_' 'int RSA_'
- '';
+ outputs = [ "out" "man" "dev" "lib" ];
- nativeBuildInputs = [ pkgconfig cmake ];
- buildInputs = [ libressl libuv zlib ];
enableParallelBuilding = true;
+ nativeBuildInputs = [ pkgconfig cmake ninja ];
+ buildInputs = [ libressl libuv zlib ];
- meta = {
+ meta = with stdenv.lib; {
description = "Optimized HTTP/1 and HTTP/2 server";
homepage = https://h2o.examp1e.net;
- license = stdenv.lib.licenses.mit;
- maintainers = [ stdenv.lib.maintainers.thoughtpolice ];
- platforms = stdenv.lib.platforms.linux;
+ license = licenses.mit;
+ maintainers = with maintainers; [ thoughtpolice ];
+ platforms = platforms.linux;
};
}