aboutsummaryrefslogtreecommitdiff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2019-09-19 22:09:57 +0200
committerMartin Weinelt <hexa@darmstadt.ccc.de>2019-09-19 22:29:31 +0200
commitfb9b7446ee0f2e57e6819982121ac01fa15d9601 (patch)
treef2cf6d7b0a51fcf921f0c01289b790316e77c8e6 /pkgs/os-specific
parent262b328b0bad0c4b97ed495679208e4a2eb87704 (diff)
piper: temporarily propagate gobject-introspection
On startup piper would be unable to find Pango: > ImportError: Typelib file for namespace 'Pango', version '1.0' not found Workaround for #56943
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/piper/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/piper/default.nix b/pkgs/os-specific/linux/piper/default.nix
index e177b284bbd..be3a5612a29 100644
--- a/pkgs/os-specific/linux/piper/default.nix
+++ b/pkgs/os-specific/linux/piper/default.nix
@@ -16,8 +16,12 @@ python3.pkgs.buildPythonApplication rec {
};
nativeBuildInputs = [ meson ninja gettext pkgconfig wrapGAppsHook desktop-file-utils appstream-glib gobject-introspection ];
- buildInputs = [ gtk3 glib gnome3.adwaita-icon-theme python3 ];
- propagatedBuildInputs = with python3.pkgs; [ lxml evdev pygobject3 ];
+ buildInputs = [
+ gtk3 glib gnome3.adwaita-icon-theme python3
+ ];
+ propagatedBuildInputs = with python3.pkgs; [ lxml evdev pygobject3 ] ++ [
+ gobject-introspection # fixes https://github.com/NixOS/nixpkgs/issues/56943 for now
+ ];
postPatch = ''
chmod +x meson_install.sh # patchShebangs requires executable file