aboutsummaryrefslogtreecommitdiff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2019-09-03 19:38:17 -0500
committerworldofpeace <worldofpeace@protonmail.ch>2019-09-13 20:59:17 -0400
commitaaf0ccfa4da6d1413de9886ec26565d635beda44 (patch)
treebc71caa68f7cb666d8a0bd08ace18c34ba644c62 /pkgs/os-specific
parentf0779e4497842b7a0306c7ae1e63d84d5ddbae75 (diff)
iwd: 0.19 -> 0.20
* don't use deprecated dbus directory * alphabetize * drop Mic92 from maintainers https://github.com/NixOS/nixpkgs/pull/68063#discussion_r323113385 * enableParallelBuilding Co-authored-by: worldofpeace <worldofpeace@protonmail.ch>
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/iwd/default.nix36
1 files changed, 23 insertions, 13 deletions
diff --git a/pkgs/os-specific/linux/iwd/default.nix b/pkgs/os-specific/linux/iwd/default.nix
index a1bb98b8297..dcca5864b52 100644
--- a/pkgs/os-specific/linux/iwd/default.nix
+++ b/pkgs/os-specific/linux/iwd/default.nix
@@ -1,14 +1,22 @@
-{ stdenv, fetchgit, autoreconfHook, pkgconfig, ell, coreutils, readline, python3Packages }:
+{ stdenv
+, fetchgit
+, fetchpatch
+, autoreconfHook
+, pkgconfig
+, ell
+, coreutils
+, readline
+, python3Packages
+}:
stdenv.mkDerivation rec {
pname = "iwd";
-
- version = "0.19";
+ version = "0.20";
src = fetchgit {
url = https://git.kernel.org/pub/scm/network/wireless/iwd.git;
rev = version;
- sha256 = "0848r06bnx5k6wlmy425hljc3f03x9xx0r83vdvf630jryc9llmz";
+ sha256 = "03ca47d4hn28vkf5fr6ck1gz5py4lm1pw3nw9s1ckw7cqxw961sf";
};
nativeBuildInputs = [
@@ -19,8 +27,8 @@ stdenv.mkDerivation rec {
buildInputs = [
ell
- readline
python3Packages.python
+ readline
];
pythonPath = [
@@ -29,13 +37,13 @@ stdenv.mkDerivation rec {
];
configureFlags = [
- "--with-dbus-datadir=${placeholder "out"}/etc/"
+ "--enable-external-ell"
+ "--enable-wired"
+ "--localstatedir=/var/"
"--with-dbus-busdir=${placeholder "out"}/share/dbus-1/system-services/"
- "--with-systemd-unitdir=${placeholder "out"}/lib/systemd/system/"
+ "--with-dbus-datadir=${placeholder "out"}/share/"
"--with-systemd-modloaddir=${placeholder "out"}/etc/modules-load.d/" # maybe
- "--localstatedir=/var/"
- "--enable-wired"
- "--enable-external-ell"
+ "--with-systemd-unitdir=${placeholder "out"}/lib/systemd/system/"
];
postUnpack = ''
@@ -55,16 +63,18 @@ stdenv.mkDerivation rec {
postFixup = ''
substituteInPlace $out/share/dbus-1/system-services/net.connman.ead.service \
- --replace /bin/false ${coreutils}/bin/false
+ --replace /bin/false ${coreutils}/bin/false
substituteInPlace $out/share/dbus-1/system-services/net.connman.iwd.service \
- --replace /bin/false ${coreutils}/bin/false
+ --replace /bin/false ${coreutils}/bin/false
'';
+ enableParallelBuilding = true;
+
meta = with stdenv.lib; {
homepage = https://git.kernel.org/pub/scm/network/wireless/iwd.git;
description = "Wireless daemon for Linux";
license = licenses.lgpl21;
platforms = platforms.linux;
- maintainers = [ maintainers.mic92 ];
+ maintainers = with maintainers; [ dtzWill ];
};
}