aboutsummaryrefslogtreecommitdiff
path: root/pkgs/data
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2019-09-21 01:41:46 -0500
committerGitHub <noreply@github.com>2019-09-21 01:41:46 -0500
commit03888ff8de5da5bdb44232d5891cc4167d7fc428 (patch)
tree598fd34e2499d8d360940dfdceec614c4322a439 /pkgs/data
parent639771fa5decfdd5813b0017199042bb2289f8fa (diff)
parent319710d48c91c3ccb717e10ed266f2779a88f54e (diff)
Merge pull request #69071 from marsam/init-cascadia-code
cascadia-code: init at 1909.16
Diffstat (limited to 'pkgs/data')
-rw-r--r--pkgs/data/fonts/cascadia-code/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/data/fonts/cascadia-code/default.nix b/pkgs/data/fonts/cascadia-code/default.nix
new file mode 100644
index 00000000000..ddb214c49e1
--- /dev/null
+++ b/pkgs/data/fonts/cascadia-code/default.nix
@@ -0,0 +1,27 @@
+{ lib, fetchurl }:
+
+let
+ pname = "cascadia-code";
+ version = "1909.16";
+in
+fetchurl {
+ name = "${pname}-${version}";
+ url = "https://github.com/microsoft/cascadia-code/releases/download/v${version}/Cascadia.ttf";
+
+ downloadToTemp = true;
+ recursiveHash = true;
+
+ postFetch = ''
+ install -Dm444 $downloadedFile $out/share/fonts/truetype/Cascadia.ttf
+ '';
+
+ sha256 = "0nckczvak3pd1h3fiz0j827pm87px9swx60q07lc2jnjlxcghgl2";
+
+ meta = with lib; {
+ description = "Monospaced font that includes programming ligatures and is designed to enhance the modern look and feel of the Windows Terminal";
+ homepage = "https://github.com/microsoft/cascadia-code";
+ license = licenses.ofl;
+ maintainers = [ maintainers.marsam ];
+ platforms = platforms.all;
+ };
+}