aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/ldap.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2019-03-27 01:46:19 +0100
committerFlorian Klink <flokli@flokli.de>2019-03-27 02:53:56 +0100
commit0a1451afe366873890c1df7a2fc6532ccc39f6bf (patch)
tree50e6ef3ce68a9bf1a23313a0ad4484f74bae115d /nixos/tests/ldap.nix
parent2dc4153633f2184f5612446b3a2ba7f999cfe5fe (diff)
nixos/ldap: rename password file options properly
users.ldap.daemon.rootpwmodpw -> users.ldap.daemon.rootpwmodpwFile users.ldap.bind.password -> users.ldap.bind.passwordFile as users.ldap.daemon.rootpwmodpw never was part of a release, no mkRenamedOptionModule is introduced.
Diffstat (limited to 'nixos/tests/ldap.nix')
-rw-r--r--nixos/tests/ldap.nix5
1 files changed, 2 insertions, 3 deletions
diff --git a/nixos/tests/ldap.nix b/nixos/tests/ldap.nix
index b3fd42e7588..18a6a2e89fe 100644
--- a/nixos/tests/ldap.nix
+++ b/nixos/tests/ldap.nix
@@ -28,9 +28,8 @@ let
users.ldap.daemon = {
enable = useDaemon;
rootpwmoddn = "cn=admin,${dbSuffix}";
- rootpwmodpw = "/etc/nslcd.rootpwmodpw";
+ rootpwmodpwFile = "/etc/nslcd.rootpwmodpw";
};
- # NOTE: password stored in clear in Nix's store, but this is a test.
environment.etc."nslcd.rootpwmodpw".source = pkgs.writeText "rootpwmodpw" dbAdminPwd;
users.ldap.loginPam = true;
users.ldap.nsswitch = true;
@@ -38,7 +37,7 @@ let
users.ldap.base = "ou=posix,${dbSuffix}";
users.ldap.bind = {
distinguishedName = "cn=admin,${dbSuffix}";
- password = "/etc/ldap/bind.password";
+ passwordFile = "/etc/ldap/bind.password";
};
# NOTE: password stored in clear in Nix's store, but this is a test.
environment.etc."ldap/bind.password".source = pkgs.writeText "password" dbAdminPwd;