aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2018-08-11 00:07:10 +0200
committeraszlig <aszlig@nix.build>2018-08-11 00:07:10 +0200
commitf51dc2a94be84b17fefb97884c14f3bdaafe6031 (patch)
treeafd1cd0aba4ef305cd73b012455a4ac70332068f /nixos/tests/installer.nix
parent2cf2ea1c03c4811f7533ce2539e86f0efa2dbecc (diff)
nixos/tests/luksroot: Fix OCR of passphrase prompt
Since a9d69a74d6edb6bcca29b1189d4bc3b203ecaf25, the passphrase prompt now no longer starts with "Enter passphrase for" but now it's just "Passphrase for", which causes the luksroot installer test to fail. I've tested this on a x86_64-linux machine and the test now succeeds. Signed-off-by: aszlig <aszlig@nix.build> Cc: @oxij, @samueldr Issue: #29441
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 2455b9152bd..507665190a2 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -467,7 +467,7 @@ in {
enableOCR = true;
preBootCommands = ''
$machine->start;
- $machine->waitForText(qr/Enter passphrase/);
+ $machine->waitForText(qr/Passphrase for/);
$machine->sendChars("supersecret\n");
'';
};