aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/installer.nix
diff options
context:
space:
mode:
authorVenkateswara Rao Mandela <venkat.mandela@gmail.com>2019-03-07 15:06:40 +0530
committerVenkateswara Rao Mandela <venkat.mandela@gmail.com>2019-07-11 17:38:25 +0530
commitb08400a4d2b81e0e680ce08f502c2d2b1c43367f (patch)
treeab4db711a6267b5cbba13070223b26e3a4a00d50 /nixos/tests/installer.nix
parentc400ab55d692d862a938b0c9d02fdc1cd402c6ff (diff)
nixos/tests: installer: restructure simpleUefiGrub test data
Diffstat (limited to 'nixos/tests/installer.nix')
-rw-r--r--nixos/tests/installer.nix31
1 files changed, 16 insertions, 15 deletions
diff --git a/nixos/tests/installer.nix b/nixos/tests/installer.nix
index 2db9d283f2b..36206b199e7 100644
--- a/nixos/tests/installer.nix
+++ b/nixos/tests/installer.nix
@@ -321,17 +321,7 @@ let
'';
};
-in {
-
- # !!! `parted mkpart' seems to silently create overlapping partitions.
-
-
- # The (almost) simplest partitioning scheme: a swap partition and
- # one big filesystem partition.
- simple = makeInstallerTest "simple" simple-test-config;
-
- # Simple GPT/UEFI configuration using systemd-boot with 3 partitions: ESP, swap & root filesystem
- simpleUefiSystemdBoot = makeInstallerTest "simpleUefiSystemdBoot"
+ simple-uefi-grub-config =
{ createPartitions =
''
$machine->succeed(
@@ -350,10 +340,20 @@ in {
"mount LABEL=BOOT /mnt/boot",
);
'';
- bootLoader = "systemd-boot";
+ bootLoader = "grub";
+ grubUseEfi = true;
};
+in {
+
+ # !!! `parted mkpart' seems to silently create overlapping partitions.
+
+
+ # The (almost) simplest partitioning scheme: a swap partition and
+ # one big filesystem partition.
+ simple = makeInstallerTest "simple" simple-test-config;
- simpleUefiGrub = makeInstallerTest "simpleUefiGrub"
+ # Simple GPT/UEFI configuration using systemd-boot with 3 partitions: ESP, swap & root filesystem
+ simpleUefiSystemdBoot = makeInstallerTest "simpleUefiSystemdBoot"
{ createPartitions =
''
$machine->succeed(
@@ -372,10 +372,11 @@ in {
"mount LABEL=BOOT /mnt/boot",
);
'';
- bootLoader = "grub";
- grubUseEfi = true;
+ bootLoader = "systemd-boot";
};
+ simpleUefiGrub = makeInstallerTest "simpleUefiGrub" simple-uefi-grub-config;
+
# Same as the previous, but now with a separate /boot partition.
separateBoot = makeInstallerTest "separateBoot"
{ createPartitions =