aboutsummaryrefslogtreecommitdiff
path: root/nixos/tests/hibernate.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2018-04-29 23:39:25 +0200
committeraszlig <aszlig@nix.build>2018-04-29 23:46:47 +0200
commit146cb02542989d67f6bb11e1206562f44c0e1eec (patch)
tree158c18750c8eeddd7380a98b35663b6d00c031d9 /nixos/tests/hibernate.nix
parentff3fe105f209a5e934b4062a9259e1e0cc587c8e (diff)
nixos/tests/hibernate: Fix netcat flags
I'm not sure why 024b501907eafbd89624e465ff21afbc96e9fec6 used -q 0 because even netcat-openbsd has the -N flag which IMO is the better way to shutdown the socket on EOF. Our default netcat implementation has changed once again[1] in 3c3b82234a6faa5a4c07323d0066452055d1ea81 and we're now using LibreSSL's implementation, which doesn't have a -q flag. See https://github.com/NixOS/nixpkgs/pull/39634 for the pull request introducing the switch. [1]: https://github.com/NixOS/nixpkgs/pull/19982 Signed-off-by: aszlig <aszlig@nix.build> Cc: @matthewbauer, @dtzWill, @Mic92
Diffstat (limited to 'nixos/tests/hibernate.nix')
-rw-r--r--nixos/tests/hibernate.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/tests/hibernate.nix b/nixos/tests/hibernate.nix
index a95235887e8..3ae2bdffed9 100644
--- a/nixos/tests/hibernate.nix
+++ b/nixos/tests/hibernate.nix
@@ -37,7 +37,7 @@ import ./make-test.nix (pkgs: {
$machine->waitForShutdown;
$machine->start;
$probe->waitForUnit("network.target");
- $probe->waitUntilSucceeds("echo test | nc machine 4444 -q 0");
+ $probe->waitUntilSucceeds("echo test | nc machine 4444 -N");
'';
})