aboutsummaryrefslogtreecommitdiff
path: root/nixos/release-small.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-20 19:23:55 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-03-20 19:46:18 +0100
commit0461f3589499168867e2de88c78f32e44c8ed557 (patch)
tree364d7766e5b06e31be247303793928ff0ea67503 /nixos/release-small.nix
parent738cf42639c6e45b097bb1fd29508e95a36eb5c0 (diff)
Rename scrubDrv -> hydraJob and make it more effective
It now strictly evaluates all remaining attributes, preventing unevaluated thunks that cannot be garbage-collected. It's also applied to all jobs in Nixpkgs' release.nix. This reduces hydra-eval-jobs' memory consumption on the 14.12 release-combined jobset from 5.1 GB to 2.0 GB.
Diffstat (limited to 'nixos/release-small.nix')
-rw-r--r--nixos/release-small.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/release-small.nix b/nixos/release-small.nix
index 7f53a101bdf..11155c85369 100644
--- a/nixos/release-small.nix
+++ b/nixos/release-small.nix
@@ -79,7 +79,7 @@ in rec {
vim;
};
- tested = pkgs.releaseTools.aggregate {
+ tested = lib.hydraJob (pkgs.releaseTools.aggregate {
name = "nixos-${nixos.channel.version}";
meta = {
description = "Release-critical builds for the NixOS channel";
@@ -88,6 +88,6 @@ in rec {
constituents =
let all = x: map (system: x.${system}) supportedSystems; in
[ nixpkgs.tarball ] ++ lib.collect lib.isDerivation nixos;
- };
+ });
}