aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/web-apps/moodle.nix
diff options
context:
space:
mode:
authorAaron Andersen <aaron@fosslib.net>2019-09-16 08:03:37 -0400
committerAaron Andersen <aaron@fosslib.net>2019-09-16 08:03:37 -0400
commit7491f85e4faa1be03572f25787e2577bd4ac5962 (patch)
tree092fe951e5a74e939fe0979a42c02e21927debc2 /nixos/modules/services/web-apps/moodle.nix
parent872122af438899db825c7f7fbec8879372c7357e (diff)
nixos/moodle: add extraConfig option
Diffstat (limited to '')
-rw-r--r--nixos/modules/services/web-apps/moodle.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nixos/modules/services/web-apps/moodle.nix b/nixos/modules/services/web-apps/moodle.nix
index 7f71b86a6fe..211bc17ee19 100644
--- a/nixos/modules/services/web-apps/moodle.nix
+++ b/nixos/modules/services/web-apps/moodle.nix
@@ -45,6 +45,8 @@ let
$CFG->aspellpath = '${pkgs.aspell}/bin/aspell';
$CFG->pathtodot = '${pkgs.graphviz}/bin/dot';
+ ${cfg.extraConfig}
+
require_once('${cfg.package}/share/moodle/lib/setup.php');
// There is no php closing tag in this file,
@@ -172,6 +174,19 @@ in
for details on configuration directives.
'';
};
+
+ extraConfig = mkOption {
+ type = types.lines;
+ default = "";
+ description = ''
+ Any additional text to be appended to the config.php
+ configuration file. This is a PHP script. For configuration
+ details, see <link xlink:href="https://docs.moodle.org/37/en/Configuration_file"/>.
+ '';
+ example = ''
+ $CFG->disableupdatenotifications = true;
+ '';
+ };
};
# implementation