aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/services/monitoring/datadog-agent.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-09-12 21:02:20 +0200
committerGitHub <noreply@github.com>2020-09-12 21:02:20 +0200
commit2865a8867faab01af76946d146c880800e1cb2e2 (patch)
tree977c12eb8000f2998f56411fbe64c23c5ac0d781 /nixos/modules/services/monitoring/datadog-agent.nix
parent4a559f8fee64bf8dc6017d66667eb42e778f819e (diff)
nixos/datadog: allow specifying dd_url (#97775)
Useful when you want to point datadog to another endpoint, either because you need a proxy to send out data, or because you use their EU endpoint.
Diffstat (limited to '')
-rw-r--r--nixos/modules/services/monitoring/datadog-agent.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/nixos/modules/services/monitoring/datadog-agent.nix b/nixos/modules/services/monitoring/datadog-agent.nix
index f1cb890794e..673bc7b02b2 100644
--- a/nixos/modules/services/monitoring/datadog-agent.nix
+++ b/nixos/modules/services/monitoring/datadog-agent.nix
@@ -6,7 +6,7 @@ let
cfg = config.services.datadog-agent;
ddConf = {
- dd_url = "https://app.datadoghq.com";
+ dd_url = cfg.ddUrl;
skip_ssl_validation = false;
confd_path = "/etc/datadog-agent/conf.d";
additional_checksd = "/etc/datadog-agent/checks.d";
@@ -77,6 +77,18 @@ in {
type = types.path;
};
+ ddUrl = mkOption {
+ description = ''
+ Custom dd_url to configure the agent with.
+ Useful when you want to point datadog to another endpoint, either
+ because you need a proxy to send out data, or because you use their EU
+ endpoint.
+ '';
+ default = "https://app.datadoghq.com";
+ example = "https://app.datadoghq.eu";
+ type = types.str;
+ };
+
tags = mkOption {
description = "The tags to mark this Datadog agent";
example = [ "test" "service" ];