aboutsummaryrefslogtreecommitdiff
path: root/nixos/lib/make-disk-image.nix
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-12-20 16:17:05 -0600
committerMatthew Bauer <mjbauer95@gmail.com>2019-01-07 16:28:50 -0600
commitf05d8f31ec944eb5b07a9dbf80b606372e47cb21 (patch)
treea4cf67a8c3f1f451bf2278fc704187f8e70c52d1 /nixos/lib/make-disk-image.nix
parent78cabc3ca9edfd04b93230aa74c132a0f81a2a25 (diff)
make-disk-image: use filterSource instead of cleanSource
cleanSource does not appear to work correctly in this case. The path does not get coerced to a string, resulting in a dangling symlink produced in channel.nix. Not sure why, but this seems to fix it. Fixes #51025. /cc @elvishjericco
Diffstat (limited to '')
-rw-r--r--nixos/lib/make-disk-image.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/lib/make-disk-image.nix b/nixos/lib/make-disk-image.nix
index bf32a36895c..6fec322f909 100644
--- a/nixos/lib/make-disk-image.nix
+++ b/nixos/lib/make-disk-image.nix
@@ -84,7 +84,7 @@ let format' = format; in let
# FIXME: merge with channel.nix / make-channel.nix.
channelSources = pkgs.runCommand "nixos-${config.system.nixos.version}" {} ''
mkdir -p $out
- cp -prd ${nixpkgs} $out/nixos
+ cp -prd ${nixpkgs.outPath} $out/nixos
chmod -R u+w $out/nixos
if [ ! -e $out/nixos/nixpkgs ]; then
ln -s . $out/nixos/nixpkgs