aboutsummaryrefslogtreecommitdiff
path: root/modules/workstation/graphics/default.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 22:09:49 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 22:09:49 +0000
commitc04d9504fa2ae8f447ef05a1e7ddb3b21ed06af9 (patch)
tree4dcadc971cabf2f96f5ef832a5664ae31c052051 /modules/workstation/graphics/default.nix
parent0a6d1447db7d1f52517a4a4c47d4198451fd223e (diff)
Adding workstation module
Diffstat (limited to 'modules/workstation/graphics/default.nix')
-rw-r--r--modules/workstation/graphics/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/workstation/graphics/default.nix b/modules/workstation/graphics/default.nix
new file mode 100644
index 00000000000..5f902759d8f
--- /dev/null
+++ b/modules/workstation/graphics/default.nix
@@ -0,0 +1,31 @@
+{ pkgs, ... }:
+
+{
+ services.xserver = {
+ enable = true;
+ desktopManager = {
+ default = "xfce";
+ xfce = {
+ enable = true;
+ noDesktop = true;
+ enableXfwm = false;
+ };
+ };
+ windowManager.i3.enable = true;
+
+ videoDrivers = [ "intel" ];
+ deviceSection = ''
+ Option "DRI" "2"
+ Option "TearFree" "true"
+ '';
+ useGlamor = true;
+ };
+
+ home-manager.users.spacekookie = { ... }: {
+ imports = [
+ ./i3
+ ./browser.nix
+ ./fun.nix
+ ];
+ };
+}