aboutsummaryrefslogtreecommitdiff
path: root/modules/systemd.nix
diff options
context:
space:
mode:
authorCornelius Mika <cornelius.mika@gmail.com>2017-08-23 17:43:46 +0200
committerRobert Helgesson <robert@rycee.net>2017-08-23 20:07:06 +0200
commit286d67878503cf05cb5d5d06660f59a1549ded09 (patch)
tree206d3866a46196a8bc4fbfee20accb70290aa532 /modules/systemd.nix
parent42ae135d38bfeae8a5fdd5f80dbc2b1aec54d177 (diff)
systemd: don't fail on activation when services changed
The diff command exits with status 1 when detecting differences. Because of 'set -e', this caused the activation to fail.
Diffstat (limited to '')
-rw-r--r--modules/systemd.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/systemd.nix b/modules/systemd.nix
index edc89ab0c87..b68034b702c 100644
--- a/modules/systemd.nix
+++ b/modules/systemd.nix
@@ -147,7 +147,7 @@ in
--old-line-format='-%L' \
--unchanged-line-format=' %L' \
"$oldServiceFiles" "$newServiceFiles" \
- > $servicesDiffFile
+ > $servicesDiffFile || true
local -a maybeRestart=( $(grep '^ ' $servicesDiffFile | cut -c2-) )
local -a toStop=( $(grep '^-' $servicesDiffFile | cut -c2-) )