aboutsummaryrefslogtreecommitdiff
path: root/modules/services/window-managers/i3.nix
diff options
context:
space:
mode:
authorMichael Hoang <Enzime@users.noreply.github.com>2019-12-27 15:24:43 +1100
committerRobert Helgesson <robert@rycee.net>2019-12-31 11:19:20 +0100
commitdf4db5063238f391352b2d334ac3e72f6fb7ade4 (patch)
treef55b5abb83052aecc7514d6aa3e29b89b07baca2 /modules/services/window-managers/i3.nix
parent54f367b1196cb23c6803bc48359512ccc39f4136 (diff)
i3: update default i3 key bindings
Update to match the default i3 key bindings https://github.com/i3/i3/blob/master/etc/config PR #957
Diffstat (limited to '')
-rw-r--r--modules/services/window-managers/i3.nix45
1 files changed, 26 insertions, 19 deletions
diff --git a/modules/services/window-managers/i3.nix b/modules/services/window-managers/i3.nix
index 412f5cc0298..7a4ec90b1cd 100644
--- a/modules/services/window-managers/i3.nix
+++ b/modules/services/window-managers/i3.nix
@@ -456,25 +456,32 @@ let
"${cfg.config.modifier}+Shift+space" = "floating toggle";
"${cfg.config.modifier}+space" = "focus mode_toggle";
- "${cfg.config.modifier}+1" = "workspace 1";
- "${cfg.config.modifier}+2" = "workspace 2";
- "${cfg.config.modifier}+3" = "workspace 3";
- "${cfg.config.modifier}+4" = "workspace 4";
- "${cfg.config.modifier}+5" = "workspace 5";
- "${cfg.config.modifier}+6" = "workspace 6";
- "${cfg.config.modifier}+7" = "workspace 7";
- "${cfg.config.modifier}+8" = "workspace 8";
- "${cfg.config.modifier}+9" = "workspace 9";
-
- "${cfg.config.modifier}+Shift+1" = "move container to workspace 1";
- "${cfg.config.modifier}+Shift+2" = "move container to workspace 2";
- "${cfg.config.modifier}+Shift+3" = "move container to workspace 3";
- "${cfg.config.modifier}+Shift+4" = "move container to workspace 4";
- "${cfg.config.modifier}+Shift+5" = "move container to workspace 5";
- "${cfg.config.modifier}+Shift+6" = "move container to workspace 6";
- "${cfg.config.modifier}+Shift+7" = "move container to workspace 7";
- "${cfg.config.modifier}+Shift+8" = "move container to workspace 8";
- "${cfg.config.modifier}+Shift+9" = "move container to workspace 9";
+ "${cfg.config.modifier}+a" = "focus parent";
+
+ "${cfg.config.modifier}+Shift+minus" = "move scratchpad";
+ "${cfg.config.modifier}+minus" = "scratchpad show";
+
+ "${cfg.config.modifier}+1" = "workspace number 1";
+ "${cfg.config.modifier}+2" = "workspace number 2";
+ "${cfg.config.modifier}+3" = "workspace number 3";
+ "${cfg.config.modifier}+4" = "workspace number 4";
+ "${cfg.config.modifier}+5" = "workspace number 5";
+ "${cfg.config.modifier}+6" = "workspace number 6";
+ "${cfg.config.modifier}+7" = "workspace number 7";
+ "${cfg.config.modifier}+8" = "workspace number 8";
+ "${cfg.config.modifier}+9" = "workspace number 9";
+ "${cfg.config.modifier}+0" = "workspace number 10";
+
+ "${cfg.config.modifier}+Shift+1" = "move container to workspace number 1";
+ "${cfg.config.modifier}+Shift+2" = "move container to workspace number 2";
+ "${cfg.config.modifier}+Shift+3" = "move container to workspace number 3";
+ "${cfg.config.modifier}+Shift+4" = "move container to workspace number 4";
+ "${cfg.config.modifier}+Shift+5" = "move container to workspace number 5";
+ "${cfg.config.modifier}+Shift+6" = "move container to workspace number 6";
+ "${cfg.config.modifier}+Shift+7" = "move container to workspace number 7";
+ "${cfg.config.modifier}+Shift+8" = "move container to workspace number 8";
+ "${cfg.config.modifier}+Shift+9" = "move container to workspace number 9";
+ "${cfg.config.modifier}+Shift+0" = "move container to workspace number 10";
"${cfg.config.modifier}+Shift+c" = "reload";
"${cfg.config.modifier}+Shift+r" = "restart";